Wijzigingen gewijzigd

Soms verbijster ik me achteraf over eerder gedane uitspraken... Op zich is de situatie sinds de vorige blog niet wezenlijk anders, en tegelijk is alles anders. Mijn servertje draait nog steeds onder Ubuntu 20.04, maar dat heeft wel heel veel voeten inde aarde gehad.

Wat is er aan de hand? Het echte antwoord weet ik (nog) niet, hoewel ik begin te vrezen voor het moederbord dan wel de voeding van de server. In het ergste geval allebei tegelijk. Sinds de wijzigingen die ik de vorige blog had beschreven wil mijn servertje niet wakker worden, na met rtcwake in een slaaptoestand te zijn gezet. Ik heb alle instellingen van de BIOS kritisch nagelopen, maar daar is niks mis mee. Wel opvallend dat ik sinds het weghalen van monitor en toetsenbord bij de server problemen heb, maar ik zie daar geen verband tussen. Vroeger draaide de server ook "headless". Wat er nu gebeurt, is dat het moederbord wel op precies de juiste tijd aangaat, maar tegelijk blijft hangen in de opstart-procdure, zelfs nog voordat verbinding met het beeldacherm gezocht wordt. Alleen de HDD-led begint te branden (continu) en verder gebeurt er niks. Dat kan er op wijzen dat de server her moeilijk heeft met het intialiseren van het SATA-subsysteem. Ik kan dan alleen verder door het systeem uit te zetten en weer aan, maar pas na het enige minuten te hebben laten hangen. Als ik onmiddellijk na het aanzetten de server uit en weer aanzet, blijft hij weer hangen, alsof het moederbordje eerst een beetje op temperatuur moet komen...

Ik heb echt allerlei oplossingen geprobeerd. In het begin dacht ik dat het aan Ubuntu lag. Ander OS gezocht en na heftig Googlen uitgekomen bij Openmediavault (OMV). En ik moet zeggen, dat is een prima oplossing. Alleen... het loste mijn rtcwake-probleem niet op, maar is wel een heel mooi systeem. Het draait op Debian, dus bekend terrein voor een Ubuntu-gebruiker. Maar het lukt me niet om het te installeren over een zelf geïnstalleerde versie van Debian heen, dus moest ik de volledige OMV-installatie zijn gang laten gaan. En die wil een HDD voor zichzelf hebben. Daar ging dus de server-SSD aan op, waarvan voortaan maar 1% gebruikt werd. Dat had ik uiteindelijk wel kunnen oplossen met GParted, maar zover is het niet komen. Terwijl ik aan het oetelen was liet één van de HDDs van mijn ZFS-RAID het afweten. "Kadoeng! Kadoeng! Kadoeng!" en soortgelijke geluiden kwam er uit het servertje. Getverderrie! Dat btekent geld uitgeven. De ZFS-pool kon ik voorlopig in "degraded" toestand blijven benaderen, maar dat is alleen een noodoplissing. Volgende storing betekent dan alles kwijt! € 125,= uitgegeven. De kapotte WD-Red 6 TB SATA-drive uitgebouwd en een Toshiba P300 6 TB ingebouwd. Dat werkte op zich goed. Tegelijk OMV weer vervangen door Ubuntu 20.04. Hoe goed OMV ook is, het loste mijn rtcwake-probleem niet op en het is geen panel-app. Je kun er dus geen virtuale webservers mee definiëren. Dan maar terug naar Ububntu met Virtualmin en de ZFS-pool een "resilver"opdracht gegeven. Dat heeft er ongeveer 40 uur over gedaan om mijn RAiD weer volledig online te krijgen, maar het ìs gelukt. Hiephoi!

Nu even rust op het server-front, hoewel het me tegenstaat om het servertje continu te laten draaien. Eens kijken of hij via rtcwake wel in (en vooral ook: uit!) de stand-by stand wil komen.

Datum
vr, 03-09-2021