Het feit dat ik tussen 17/9/19 en vandaag hier niks heb geplaatst, zou kunnen suggereren dat er in die periode niks gebeurd is. FOUT! Er is juist zoveel gebeurd dat het niet  interessant is om elk stapje op te schrijven.

Het probleem waar ik mee te maken kreeg was mijn DLNA-server, die met de app Serviio geïnstalleerd was op de thuisserver. Dat werkte niet meer in de nieuwe setup op de herstelde thuisserver. Dus kon ik op tv niet meer grasduinen door mijn verzameling films en tv-series. Hoe moest ik Serviio weer aan de praat krijgen? Ik heb de beschikbare versies gedownload, maar liep ertegen aan dat ik daarvoor geen geldige licentie heb. En dat terwijl ik die vroeger wel had.

Eerst geprobeerd mijn destijdse Serviio setup van een backup terug te halen. Dat was Serviio 1.9.2. Maar het hielp niet om dat vanaf de backup af te halen. Waarschijnlijk heb ik gewoon te weinig teruggehaald, of was het te zeer afhankelijk van de setup waarin het draaide.
Wat ook niet kon was een complete backup terug zetten. Die was immers gemaakt in een andere omgeving (ander moederbord), dus andere setup. Bovendien bleek dat die backup niet slim was opgebouwd. (Zucht...)
Toen een truck uitgehaald: versie 16.04 van Ubuntu server geïnstalleerd. Toen een upgrade gedaan naar een 18.04.1 versie. Daarover heen een complete backup gezet die was gemaakt toen ik nog op 18.04.03 draaide met het oude moederbord. Na enig gevogel in fstab en netplan wilde dat nog opstarten ook. En Serviio werd ook nog actief!
Maar daarmee was verder niks opgelost. De meeste reboots bleven steken tijdens opstarten. Er moest voortdurend worden getuned om een draaiend systeem te krijgen.... het werkte gewoon niet lekker.

Diepe, zeer diepe zucht...

Uiteindelijk hélemaal overnieuw begonnen. De laatste versie van Ubuntu Server 18.04.3 gedownload en geïnstalleerd op de thuisserver. Daarop Webmin, Usermin en Virtuamin gezet. En uiteindelijk ook Serviio 2.0. Voor dat laatste heb ik nu geen geldige licentie, maar daarmee moet ik wel op tv bij mijn bestanden kunnen. Serviio 1.9.2 is afhankelijk van een java-setup die niet geldig meer is op de huidige versie van Ubuntu.
Toen dat allemaal goed draaide heb ik het systeem geüpgrade naar release 19.04 en daarna naar 19.10.
En dat werkt nu allemaal naar behoren! Alleen nog Drupal installeren en we zijn waar we zijn willen.

Pffft....

 

 

Datum
di, 05-11-2019